Downgrade do Mozilla Firefox para versão 3.5.9

Olá pessoal, esta semana enfrentei um problemão no trabalho, onde temos um servidor rodando o Ubuntu e diversas máquinas virtualizadas rodando no VMWare.

O problema começou quando o Firefox atualizou sua versão para a 3.6.16 e o plugin do VMWare parou de funcionar. Após pesquisar um pouco na net descobri que esse plugin não é compatível com as versões posteriores à 3.5.9 do Firefox e que seria necessário fazer um downgrade para a versão 3.5.9 para que o problema fosse corrigido, porém mesmo selecionando a versão 3.5, o Synaptic forçava o download da versão mais recente (3.6.16) e persistia o problema.

A saída foi fazer o downgrade manual do Firefox, baixando a versão 3.5.9 e instalando através do terminal.

No próprio site do Mozilla tem um passo a passo ensinando como fazer esta instalação apenas extraindo os arquivos e abrindo via terminal com o comando.

~/firefox-3.5.9/firefox

Mas na vida real isso não funciona, pois o arquivo baixado ainda não está compilado, sendo necessário portanto, rodar o compilador SH para que o Firefox possa ser executado. Isso poderá ser feito com os comandos a seguir, no terminal:


~/firefox-3.5.9 - vai na pasta onde estão os arquivos descompactados
sudo chmod +x firefox - dar pemissão de execução no arquivo
sudo sh firefox - sudo para instalar o arquivo SH

Após estes comandos o Firefox abrirá uma tela de instalação durante alguns segundos e logo em seguida abrirá a sua janela principal de navegação. Nesta versão instalada o plugin para o console do VMware é compatível e já deverá abrir a janela para acesso às máquinas.
No meu caso o firefox fica aberto o tempo todo então não criei atalho para ele, mas recomendo criar um para não ter todo esse trabalho novamente na próxima vez que for usar o Firefox.

Espero ter ajudado muita gente a não perder uns dia de trabalho quebrando cabeça igual a mim rsrs. Abs!

Deixe uma resposta